New Page 1

Introduction

Atmel’s AT91SAM7S64 is a member of a series of low pincount Flash microcontrollers based on the 32-bit ARM RISC processor. It features a 64 Kbyte high-speed Flash and a 16 Kbyte SRAM, a large set of peripherals, including a USB 2.0 device, and a complete set of system functions minimizing the number of external components. The device is an ideal migration path for 8-bit microcontroller users looking for additional performance and extended memory.
The embedded Flash memory can be programmed in-system via the JTAG-ICE interface or via a parallel interface on a production programmer prior to mounting. Built-in lock bits and a security bit protect the firmware from accidental overwrite and preserves its confidentiality.
The AT91SAM7S64 system controller includes a reset controller capable of managing the power-on sequence of the microcontroller and the complete system. Correct device operation can be monitored by a built-in brownout detector and a watchdog running off an integrated RC oscillator.
The AT91SAM7S64 is a general-purpose microcontroller. Its integrated USB Device port makes it an ideal device for peripheral applications requiring connectivity to a PC or cellular phone. Its aggressive price point and high level of integration pushes its scope of use far into the cost-sensitive, high-volume consumer market.

The AT91SAM7-P64 Development board is designed to evaluate AT91SAM7S64 processor. It has the following features:
- standard JTAG connector with ARM 2x10 pin layout for programming/debugging with ARM-JTAG
- two channel RS232 interface and drivers
- on board voltage regulator 3.3V with up to 800mA current
- single power supply: 6V AC or DC required
- power supply LED
- two status LEDs
- two buttons
- SD/MMC connector
- power supply filtering capacitor
- trimpot connected to ADC
- thermistor connected to ADC
- RESET circuit with RESET button
- 12 Mhz crystal on socket
- extension headers for all uC ports
- PCB: FR-4, 1.5 mm (0,062"), green soldermask, white silkscreen component print
- Dimensions: 120x80 mm (4.7x3.2")

The purpose of this guide is to describe AT91SAM7-P64 Development board.

Board | AT91SAM7-P64
Hardware details | Describes the hardware peripherials in detail
Revision | 01.08.2005 Creating

Copyright (c) OLIMEX Ltd. All rights reserved


Picture

This is picture of AT91SAM7-P64 Development board.

Board AT91SAM7-P64

Copyright (c) OLIMEX Ltd. All rights reserved


AT91SAM7-P64


AT91SAM7-P64 Board


AT91SAM7-P64 Hardware description

Peripherials

Unit | Description
COM Port1 | RS232 DB9 Female connector for AT91SAM7S64 USART0.
COM Port2 | RS232 DB9 Female connector for AT91SAM7S64 USART1.
JTAG Connector | 2x10 0,1" step connector for programming with ARM-JTAG.
SD/MMC connector | Connector for external MMC cards.
USB connector | USB connector Type B.
Extension ports | 31 pins, 0,1" extension ports EXT1
Buttons | Button1 connected to PA19 / RK / FIQ / AD2 (PIN 13) Button2 connected to PA20 / RF / IRQ0 / AD3 (PIN 16)
Led | Green status led connected (Led2) to PA17 / TD / PCK1 / AD0 (PIN 9) via jumper - Jumper5 Yellow status led connected (Led3) to PA18 / RD / PCK2 / AD1 (PIN 10) via jumper - Jumper6 Red power led indicator (Led1)

Technical characteristics

Parameter | Description
Voltage Supply | min 6.0V DC, max 9.0V DC min 4.5V AC, max 6.0V AC
CPU | AT91SAM7S64
Crystals | Q1 - 12 MHz HF crystal
Board dimensions | 120x80 mm (4.7x3.2")
PCB | FR-4, 1.5 mm (0,062"), green soldermask, white silkscreen component print
Operating Temperature | form 0ºC to 70ºC

JTAG Connector

Pin / Name | Connected to: | Functionality
1 - VCC | VCC | -
2 - VCC | VCC | -
3 - TRST | VCC via R1 (47K) | -
4 - GND | GROUND | -
5 - TDI | PIN 33 | TDI
6 - GND | GROUND | -
7 - TMS | PIN 51 | TMS
8 - GND | GROUND | -
9 - TCK | PIN 53 | TCK
10 - GND | GROUND | -
11 - RTCK | TCK via R5 | -
12 - GND | GROUND | -
13 - TDO | PIN 49 | TDO
14 - GND | GROUND | -
15 - RST | PIN 39 | NRST
16 - GND | GROUND | -
17 - - | no connected | -
18 - GND | GROUND | -
19 - - | no connected | -
20 - GND | GROUND | -

RS232 Connector 1 (RS232_0/D)

Pin / Name | Connected to: | Functionality
1 - CD | not connected | -
2 - RXD | PIN 35 (via Jumper3) | PA5 / RXD0 / NPCS3
3 - TXD | PIN 34 (via Jumper4) | PA6 / TXD0 / PCK0
4 - DTR | not connected | -
5 - GND | GROUND | -
6 - DSR | not connected | -
7 - RTS | not connected | -
8 - CTS | not connected | -
9 - RI | not connected | -

RS232 Connector 2 (RS232_1)

Pin / Name | Connected to: | Functionality
1 - CD | not connected | -
2 - RXD | PIN 11 | PA21 / RXD1 / PCK2
3 - TXD | PIN 14 | PA22 / TXD1 / NPCS3
4 - DTR | not connected | -
5 - GND | GROUND | -
6 - DSR | not connected | -
7 - RTS | not connected | -
8 - CTS | not connected | -
9 - RI | not connected | -

SD/MMC Connector

Pin / Name | Connected to: | Functionality
1 - CD/DAT3/CS | PIN 28 | PA11 / NPCS0 / PWM0
2 - CMD/DI | PIN 22 | PA12 / MOSI / PWM2
3 - VSS1 | GROUND | -
4 - VDD | +3.3V | -
5 - CLK/SCLK | PIN 21 | PA14 / SPCK / PWM3
6 - VSS2 | GROUND | -
7 - DAT0/DO | PIN 27 | PA12 / MISO / PWM0
8 - DAT1/RES | not connected | -
9 - DAT2/RES | not connected | -
10 - WP1 | GROUND (via R23) | PA16 / TK / TIOB1
11 - WP2 | +3.3V | -
12 - CP1 | +3.3V | -
13 - CP2 | GROUND (via R22) | PA15 / TF / TIOA1

WP - write protect
CP - card present

Jumpers

Jumpers | Position | Description
Jumper 1 (BDS) |  | Enable normal mode.
 |  | The pin JTAGSEL is used to select the JTAG boundary scan.
Jumper 2 (TST) |  | Enable normal mode.
 |  | The pin TST is used for manufacturing test or fast programming mode.
Jumper 3 (RXD0/DRXD) Jumper 4 (TXD0/DTXD) |  | RS232_0 is not connected
 |  | RS232_0 is connected to RXD0 and TXD0 (USART0)
 |  | RS232_0 is connected to DRXD and DTXD which is used in programming mode - via COM Port.
Jumper 5 (LED_J) |  | Green led is not connected.
 |  | Green led connected to PA17 / TD / PCK1 / AD0 (PIN 9)
Jumper 6 (LED 1) |  | Yellow led is not connected
 |  | Yellow led connected to PA18 RD PCK2 AD1 (PIN 10)
Jumper 7 (VREF_P) |  | ADVREF pin (PIN 1) is connected to VREF pin.
 |  | ADVREF pin (PIN 1) is connected to 3.3V.

Description for programming via RS232_0 COM port, when is SAM-BA software.

The AT91SAM7-P64 can to be programming via COM port using the SAM-BA™ software. Before being able to use SAM-BA, a recovery procedure which consists of copying the SAM-BA Boot Assistant into Flash must be performed as follows:
1. Power down the AT91SAM7-P64
2. Close the Jumper2 named TST
3. Power up the AT91SAM7-P64
4. Wait 10s
5. Power down the AT91SAM7-P64
6. Remove the Jumper2 named TST
7. Power up the AT91SAM7-P64

NOTE: To programming via COM port, you must set Jumper3 and Jumper4 which is describe above.


Links

1. Atmel web site

AT91SAM7Sxxx product datasheets, application notes, etc info:
http://www.atmel.com/

2. Atmel ARM microcontrollers discussion forum

http://www.at91.com/ - forum for discussions on AT91 ARM microcontrollers

http://groups.yahoo.com/group/arm-olimex/ - forum for discussions on Olimex ARM boards

3. IAR Systems EW-ARM C compiler and debugger

http://www.iar.com/Products/?name=EWARM

4. Rowley associates CrossWorks for ARM C compiler and debugger

http://www.rowley.co.uk